Stratagus 2.3

User avatar
Kyran
Posts: 499
Joined: Sat Dec 31, 2011 5:19 pm
Location: Australia
Contact:

Re: Stratagus 2.2.8

Postby Kyran » Tue Dec 10, 2013 1:22 pm

So the plan is for 2.2.8 to be the last released on SDL1? We'll do some rebranding for Stratagus 3. :)

Who here is able to compile some binaries? I'll try to produce some for Ubuntu 13.04, Ubuntu 13.10, and Raspbian.
04:27 jim4 why haven't you added wc1 support? this project sucks. i'm only going to use freecraft
05:06 jim4 finished wc1 support yet? i've been waiting for 6 years
05:10 jim4 new things scare me
User avatar
cybermind
Posts: 110
Joined: Sat Dec 31, 2011 11:43 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Stratagus 2.2.8

Postby cybermind » Mon Dec 16, 2013 11:24 pm

I've updated changelog of Stratagus' new release in trunk. There are too many new features and changes, so the next version of Stratagus could be easily called "2.3" :)
User avatar
Andrettin
Posts: 433
Joined: Sun Jun 30, 2013 9:58 pm
Location: Vienna, Austria
Contact:

Re: Stratagus 2.2.8

Postby Andrettin » Tue Dec 17, 2013 12:03 am

cybermind wrote:I've updated changelog of Stratagus' new release in trunk. There are too many new features and changes, so the next version of Stratagus could be easily called "2.3" :)
I took a look at the changelog, and the changes sound pretty cool :)

EDIT: Are any changes to the Lua scripts necessary for them to work with the new Stratagus version? If so, what would those be?
User avatar
DinkyDyeAussie
Posts: 260
Joined: Fri Feb 10, 2012 10:39 am
Location: Australia
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Stratagus 2.2.8

Postby DinkyDyeAussie » Thu Dec 19, 2013 12:50 pm

Here's the latest Win32 binaries.
Stratagus_binaries.zip
Latest trunk release and debug win32 binery compiles.
(2.61 MiB) Downloaded 336 times
User avatar
Kyran
Posts: 499
Joined: Sat Dec 31, 2011 5:19 pm
Location: Australia
Contact:

Re: Stratagus 2.3

Postby Kyran » Thu Dec 19, 2013 3:44 pm

Your binary doesn't like videos.

I'll push the updates to trunk in preparation of the next version.
04:27 jim4 why haven't you added wc1 support? this project sucks. i'm only going to use freecraft
05:06 jim4 finished wc1 support yet? i've been waiting for 6 years
05:10 jim4 new things scare me
User avatar
DinkyDyeAussie
Posts: 260
Joined: Fri Feb 10, 2012 10:39 am
Location: Australia
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Stratagus 2.3

Postby DinkyDyeAussie » Thu Dec 19, 2013 3:57 pm

dammit! Must've forgotten something in the linker...I had a feeling I did.
User avatar
Kyran
Posts: 499
Joined: Sat Dec 31, 2011 5:19 pm
Location: Australia
Contact:

Re: Stratagus 2.3

Postby Kyran » Fri Dec 27, 2013 6:33 pm

I've been playing the Frontier Force campaign on the trunk. I've noticed a few problems.

+ AI gives up attacking when the attackforce's path is blocked after a while. Attackforce's route should be recalculated every so often so the units don't just sit around doing nothing.
+ Melee units freak out when getting attacked from different sides by ranged units, seems to mainly happen around towers. The unit keeps switching targets, walking back and forth in a line.
+ Friendly units no longer attack you when you attack them, except for splash damage units (catapult).

I've been looking at how to get Stratagus into various distros. So far I've found one for Debian. They also have a PPA which would certainly be more popular than our own. Fedora has a less impressive page about their packaging.
04:27 jim4 why haven't you added wc1 support? this project sucks. i'm only going to use freecraft
05:06 jim4 finished wc1 support yet? i've been waiting for 6 years
05:10 jim4 new things scare me
User avatar
Andrettin
Posts: 433
Joined: Sun Jun 30, 2013 9:58 pm
Location: Vienna, Austria
Contact:

Re: Stratagus 2.3

Postby Andrettin » Tue Jan 07, 2014 6:22 pm

DinkyDyeAussie, thanks for compiling those .exes, but unfortunately they don't seem to work for me. When I try to use them with Aleona's Tales, Wargus or Wyrmsun, the game fails to load.
User avatar
DinkyDyeAussie
Posts: 260
Joined: Fri Feb 10, 2012 10:39 am
Location: Australia
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Stratagus 2.3

Postby DinkyDyeAussie » Sat Jan 11, 2014 1:35 am

Hmmm. That's weird, I haven't changed my compile routine, and the exe files work for me...I mean I can't load saved games, but starting a new game with the new exe files, it works fine...Maybe you need my SDL.dll file too...I dunno. :oops:
User avatar
Kyran
Posts: 499
Joined: Sat Dec 31, 2011 5:19 pm
Location: Australia
Contact:

Re: Stratagus 2.3

Postby Kyran » Sat Jan 11, 2014 7:17 am

I'm sure if you compile the latest trunk everything will work out.

For me at least.

Try deleting your configuration file, Andrettin.
04:27 jim4 why haven't you added wc1 support? this project sucks. i'm only going to use freecraft
05:06 jim4 finished wc1 support yet? i've been waiting for 6 years
05:10 jim4 new things scare me

[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Who is online

Users browsing this forum: No registered users and 1 guest