map editor glitch

Discuss your problems with the latest release of the engine here. Problems with games, maps or other utilities belong in their respective forums.
User avatar
b_o
Posts: 328
Joined: Sun Jan 01, 2012 12:07 pm

map editor glitch

Postby b_o » Mon Jan 27, 2014 2:45 pm

There seems to be a discrepancy with how the map editor displays tree tiles, and how wargus displays tree tiles in-game.
I was making some new trees, and they look fine in the map editor, but a couple of tiles are swapped in the actual game. It should be easy enough for me to fix the tileset for the game, but an update to the map editor would probably be good.
wgmaped.png
every thing looks fine in the map editor
wgmaped.png (14.47 KiB) Viewed 1523 times
wgwc1.png
glitches visible in a wargus WIP campaign map
wgwc1.png (47 KiB) Viewed 1536 times
Last edited by b_o on Tue Jan 28, 2014 1:54 pm, edited 1 time in total.
User avatar
Andrettin
Posts: 433
Joined: Sun Jun 30, 2013 9:58 pm
Location: Vienna, Austria
Contact:

Re: map editor glitch

Postby Andrettin » Mon Jan 27, 2014 6:25 pm

b_o wrote:There seems to be a discrepancy with how the map editor displays tree tiles, and how wargus displays tree tiles in-game.
I was making some new trees, and they look fine in the map editor, but a couple of tiles are swapped in the actual game. It should be easy enough for me to fix the tileset for the game, but an update to the map editor would probably be good.
A good idea, I think, would be to test a tileset in Wyrmsun's campaign map. This is because for that map the, tile types (tree, water, etc.) are coded, but the variation picked for a specific tile is random, while in the editor always the same variation seems to be chosen, regardless if (for instance) grass tiles have 3 variations. You could also generate a random map in Wyrmsun, since (besides obviously having random tile types chosen), it implements the tile variations randomly as well.
User avatar
b_o
Posts: 328
Joined: Sun Jan 01, 2012 12:07 pm

Re: map editor glitch

Postby b_o » Tue Jan 28, 2014 1:52 pm

Here is something else weird about the editor:
Notice how the top row changes, adding a new tree tile where there was none when I use a 1*1 dirt tile to remove a tree tile 2 tiles away:
c1.png
clear view of the arrangment
c1.png (10.22 KiB) Viewed 1523 times
c2.png
I place the 1*1 dirt tile over the bottom right corner tree tile
c2.png (9.55 KiB) Viewed 1523 times
c3.png
a new tree tile appears where there was none
c3.png (10.55 KiB) Viewed 1523 times

Who is online

Users browsing this forum: No registered users and 1 guest